GONKURABE

だら科日記

flutter(android)ビルド時のエラー対応(com.android.tools.lint:lint-gradle-api:26.1.2)

Error:Could not find lint-gradle-api.jar (com.android.tools.lint:lint-gradle-api:26.1.2). Searched in the following locations: https://jcenter.bintray.com/com/android/tools/lint/lint-gradle-api/26.1.2/lint-gradle-api-26.1.2.jar

上記エラーの対応メモ。

解決方法

{your flutter}/packages/flutter_tools/gradle/flutter.gradleの下記を…

repositories {
    jcenter()
    maven {
        url 'https://dl.google.com/dl/android/maven2'
    }
}

下記に変更!

repositories {
    maven {
        url 'https://dl.google.com/dl/android/maven2'
    }
    jcenter()
}

解決するまで

ログに下記のように書いてあるので、build.gradleを見に行く。

* Where: 
Build file '/Users/{your flutter project}/android/app/build.gradle' line: 25

直らない。 stackoverflowを読んだところ、flutter.gradleを変えればよさそうなことがわかりました。 stackoverflow.com